Android, Brave last update big problem! (after update April 8, same problem...)

Sorry but, with the last update the browser freezing and crashing!

Samsung Galaxy Note 10.1 2014 with Android 5.1.1 (with Total Launcher, but it’s the same with the Samsung launcher…)

At April 8: Brave Version 1.5.130

I hope this big problem will resolved really quickly…:rage:

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:

How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Mobile Device details

Additional Information:

How they managed to release such a buggy version without testing is beyond me. :drooling_face:

Did the crash start right after update launch?

Yes, right after the update!
I think it’s a bug, because now Brave works…
A few hours ago still had the same problem.

After I closed the browser, the problem came back!
First I received a notification, and Brave opened without any problems and with all my saved tabs…
I’m sure there’s a bug.

April 8 browser update, nothing new, same problem of freezing and crashing…:confused:

cc: @gsarvadnya Could you please try this on your device?

@PB21 We have released a new Hotfix ver 1.5.131. Could you try updating to this and check if it fixes the issue? Do you have any custom theme installed on your device?

1.5.131 installed, do not solve the problem.
I use Total Launcher, without any other custom theme.
But the problem is the same with the Samsung Touch wiz (the original launcher, obviously with a reboot of the device…).
It’s curious because, when I receive a Brave notification from YouTube or from a blog I follow, the browser opens without any problem and with all my tabs!
I have now tried to clear the cache, but nothing has been fixed.

This is a screen shot of the page I see when I open the browser and it freezes

@PB21 I just tried installing 1.5.113 in Android 5.1.1 (Samsung Galaxy) without any issues it got installed and I am able to use the browser.

I have upgraded brave from 1.5.120 to 1.5.130 or 1.5.131 - Upgrade is happening properly, there is no crash or freezing.

From your screenshot above it looks like you are using Android tab? If so, can you please provide the device details. Also can you elaborate a bit on the issue.

  1. Is this happening when you install build from GPS?
  2. Can you try upgrading build from 1.5.120 to 1.5.131?

Can you try installing latest 1.5.131 from GH and see whether you are seeing the same issue


  1. Is this happening when you install build from GPS?
    Yes, I installed the last version (1.5.131) from the Play store.

  2. Can you try upgrading build from 1.5.120 to 1.5.131?
    Sorry but, I upgraded from 130 to 131 (and obviously from 120 to 130…)

I think it’s not possible a downgrade to the old version…

My device is a Samsung Galaxy Note 10.1 2014 SM-P605 (tablet) with Snapdragon, Android 5.1.1., only Total Launcher (but with Samsung Touch Wiz nothing change).

Now I tried to reinstall the packages from GitHub (without uninstalling Brave), but no change…

Same issue here, on the 130 as well as the 131 android build, on a oneplus 6t running android 10. Immensely slow at startup, brave hangs for 10-20 seconds. After that, I can use it as usual, but the slow start happens at least after every phone restart, and seemingly at other random moments as well.

Glad to see I’m not the only one with this issue, I was also a bit angry that you, brave, list an email address for reporting issues (in the info in the play store), but have it on autoreply to report that we should not report stuff there because it is never read. So, my detailed report, all for nothing.

It’s been my favourite browser for quite some time, really hoping for a quick solution of the android issue.

After a new Brave notification, and consequently a correct opening of the browser, I had the opportunity to take a Screenshot directly from the browser information page.

Ok, I probably found the problem.
I’m turning off the Play Protect option in my Play Store.
Another solution probably, I delete most of the data on Manage Storage, and clear the cache for a second time.
The browser opened without problems…
On my TV box android (Minix), same Android version of the Samsung (5.1.1), upgraded Brave from 1.5.9 to 1.5.131, no issue at all.
What a misteries…, but I’m not happy for sure!

Good (not really…).
The problem is not the Play Protect, but I don’t know why, I have to go on Apps management and Brave app, Manage archiving voice (Brave software storage space) and delete the data on the first entry of the three, “Free Space”.
After that, Brave opens without problems and with all my tabs!
I think I need to export my passwords and copy my tabs to Brave beta or another browser, and do a reinstall…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.