Amazon is suddenly in Spanish. Only Amazon. Only in Brave

I clicked a link that went to a Spanish amazon page. I thought it had spent me to a foreign amazon site but now it’s all in Spanish. Other browsers are still in English.

Version 1.38.117 Chromium: 101.0.4951.67 (Official Build) (64-bit)

Open Amazon, click the language button and change it to your preference.



Duh, that worked. It was still a USA flag so I didn’t check, and I thought it would effect other browsers.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.