Am I Correct Understanding Brave and Chrome will not run in Catalina?

Am I Correct Understanding Brave and Chrome will not run in Catalina?

I think you misunderstood something. As described here, you just need MacOS Catalina 10.15 or later for a successful installation.

image

When I start Brave, a blank window opens then closes.

When I start Brave from command line:
image
blank window opens then closes.

Modified start from command line:
image

A usable window opens, containing a warning

I removed then reinstalled Brave, no change in what happens

This is very odd. Can you try to add this option --enable-logging=stderr --v=1 > debug.txt 2>&1 to your command and post the content or upload the file here?

I need to say I’m a Linux user so my knowledge in the macOS world is limited, but I try my best. :v:

Thank you for taking a look at this problem. I added --enable-logging=stderr --v=1 > debug.txt 2>&1 to the startup command. Steps:

  1. copy " --enable-logging=stderr --v=1 > debug.txt 2>&1" to a text file
  2. kill the process running Brave.app
  3. Start Brave browser from command line using the following command:

open ‘/Applications/Brave Browser.app’ --args --no-sandbox --enable-logging=stderr --v=1 > debug.txt 2>&1

  1. Come to this thread to post what I did.

The file created, debug.txt was formed but has nothing written into it…

I changed the startup command , removing the no-sandbox argument, to the following:

open ‘/Applications/Brave Browser.app’ --enable-logging=stderr --v=1 > debug.txt 2>&1

Here is what showed up in the debug.txt file.

debug.txt (1.7 KB)

Oh sorry, somehow I had the wrong command option in mind.

You only need to add the --debug option to the command. To redirect the output of it to a file, you need to add again >> at the end.

The full command looks like this:
'/Applications/Brave Browser.app' --args --debug >> debug.txt

Notice: I would recommend to delete the old debug.txt file to have a clean output before you execute the command again.

I’m very sorry that I missed mentioning you need to add open in to the command, as you did it before. :pray:

Corrected command:
open /Applications/Brave\ Browser.app --args --debug >> debug.txt

Notice:
You can use the TAB key for autocomplete this makes typing easier.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.