All tabs crash upon opening them, reinstalling did not solve the issue - Win10(64 bit)

Description of the issue:
When I opened brave this morning, all my tabs had crashed, (getting the “aw snap” message). I tried opening a new one, but got the same message directly.
Tried following the recomendation on the “how do i fix page crashes” page, but I cannot open the delete cache page as this opens in a tab that has the same message. This is the situation for ALL tabs that open in brave, rendering the browser unusable.
Incognito does not make a difference
Uninstalling and reinstalling did not work either.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
open the browser with any tab on it

Actual Result (gifs and screenshots are welcome!):

Expected result:
tabs should work

Reproduces how often:
100% of the time on my machine

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 64 bit
I cannot check the version since the about page crashes too, but I reinstalled downloading from the website, so I assume it to be latest stable at this point (june 12, 2019)

Additional Information:
No recent software installs or windows updates happened.

Wow, this community is useless. Noone will even bat an eye to even say: haven’t got the foggiest or “please provide more info”.

Anyways, in case anyone has the same issue: finally found the solution. Turns out the uninstall process for this browser is far from acceptable and leaves a lot of stuff behind. like folders in program files and program data.

Anyways, you need to delete extra stuff and then restart.
https://community.brave.com/t/how-to-solve-almost-every-problem-after-install/605
this helpful guide states how.