All screens not visible even with shields down

On some websites, all screens not visible - meaning they don’t load - even with shields down. Ameritrade is where this is a problem. Concurrently , the problem pages will load on Google Chrome.

What do you advise?

Thank you

Hi @c308682,

Can you share your Brave version, OS, screenshot of the issue, example site/s, and screenshot of your Brave shield (Brave icon at URL bar).


Brave v. 0.57.18

Unfortunately I can’t test this on my end since I don’t have an Ameritrade account.
Can you try setting your Global Shields to “Allow all” for their respective protections? This way we can see if it’s actually a Shields error or something else causing the issue.

I too have the same issue with the Ameritrade website. Some sections appear others do not; I have tried various combinations of the shields, and none help.


I am often successful by refreshing the screen 2 or 3 times. It’s unprofessional but manageable.

If anyone in this thread is willing to fill out the required info from the template for this issue I’d be happy to troubleshoot or log this if necessary.

I tried filling it out earlier in the thread but I didn’t pass the test sorry

Description of the issue:
When viewing certain sections of the website, the main frame appears empty. I have tried variations of the available shield options, including all off, but nothing works.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. log on to the website
  2. select the menu option Trade - Mutual Funds

Actual Result (gifs and screenshots are welcome!):
An empty frame, see screen shot

Expected result:
A populated frame, see screen shot

Reproduces how often:

Brave Version(about:brave):
Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Reproducible on current live release (yes/no):

Additional Information:
I am not too familiar with html programming, but if anything on the developer options would help, I would be more than happy to copy and add (as you need an account to view the troublesome website). I, also, could provide the same information from Firefox, which is the browser I use to view that site.

We released an update to v0.59.34 today, can you update and confirm whether or not the issue still occurs after the update?

The website now works as expected!
Thank you.

1 Like