"alien script detected: inline code" at DSLreports.com/speedtest

Description of the issue:

Brave displays a warning about an alien script which happens only when using Brave (regardless of extension settings, or profiles used. Chrome and other browsers do not display the warning.

How can this issue be reproduced?

  1. Go to dslreports.com/speedtest
  2. Observe warning just beneath popup speed test box

Expected result:

There shouldn’t be any warning. In straight chrome or other browsers, there is no such warning.

Brave Version( check About Brave):

Version 1.15.76 Chromium: 86.0.4240.111 (Official Build) (64-bit)

Additional Information:

I have disabled all extension (I only have three installed)
I have global shield turned off.
I have tried this with other brave profiles on the same PC (they too show the same warning)

Unfortunately, I do not have any other PCs at home on which to test other installations of Brave.

I have not attempted to reset my browser in any way (am really trying to avoid that).
Running Windows 7 Home, x64

My apologies if this is a known issue, or something unrelated to Brave. I did a cursory search on the warning and came up empty.

I went nuclear and updated my Win7 PC to Win10… Thinking MAYBE it had something to do with that, but alas, same issue.

I also installed a parallel copy of Brave Beta and with a brand new install, the script warning remains.

MS Edge does not have this message.
Dissenter browser does not have this message.

If this is the nature of the beast for Brave, sobeit, but I’d really like to know I don’t have some kind of hitchhiker riding along with my browser.

you said you tried with other profile was it a fresh one or not?

if not could you try to create a new one and try again

It was an existing one on my daily stable Brave. However after just installing Brave Beta (for the first time), it came up fresh - with what I assume is a new profile. I’ll create a new one on my regular brave now and will report back in a sec…

ETA: Regrettably, even with a brand new profile (even showed the intro tutorial) the warning is still there. arg.

the test does not even work with me it always fail to start

Ha… I guess I shouldn’t complain then. I’ve been having other issues with Brave - specifically, if it’s been open all day, it gets very lethargic - sluggish. Typing something in Gmail after it’s been open for more than a few hour would result in such a horrible delay, I’d have to close it down and re-open. Particularly bad was Google Voice in a tab after just a few back-and-forth texts. Anyway, that combined with the alien script warning, got me a little paranoid. But the slowdown doesn’t happen in other browsers.

@erkme73 you have the right to ask and complain but i am not a team member iam just a user like you who try to help when i could
so wait till the team back on monday and depend on the their position on the queue you will get your answer
so let me ask one of the team to help you
@Mattches could you help us here

and have a nice day both of you

Thanks so much… I’m not in any hurry, so if this eventually gets addressed more formally, I’m ok even if it takes some time. I appreciate your replies, too.

1 Like

Can you tell me exactly what the inline script the test is flagging is/says/looks like?

Thank you @mattches for the reply. Unfortunately I am very technically challenged when it comes to the use of the console or other tricks. And without some real hand-holding on how to dig deeper, I cannot provide more that what was in my screenshot.

The dslreports speed test simply has the very vaguely-worded:


alien script detected: inline code what is an alien script? https://www.dslreports.com/faq/17944

It does not provide any details beyond the warning. I’d be happy to do whatever you suggest to find more detail, but without guidance, I’m pretty useless…

Got it, no worries.
It is highly likely that you don’t have anything to worry about, and the “alien script” being detected is one of your installed extensions, or one of Braves built-in extensions (like Shields) being detected.

If you want to be sure, run a quick scan w/Windows Defender on your PC and see if anything gets flagged.

That’s what I’m assuming as well - especially since it appears on multiple profiles (even brand new ones without any extensions). I’m curious though, if you go to the site, dslreports.com/speedtest, do you see the warning as well? If it’s a built-in extension over which users don’t have any control, I would think this should be a warning every Brave user would see universally, no?

If you don’t see it, I’m curious if there isn’t a flag I can en/disable that would remove it - if even just temporarily to know what’s causing it.

Windows Defender hasn’t flagged anything on the PC…

Thanks again for the reply.

Interestingly – I actually can’t get the speed test to work for me at all. It claims that it can’t connect to any server. Getting CERT_DATE errors in the console.

I’ve reached out to one of our web compatibility experts for more information on this.

With Chrome or Brave I’m getting the following error: (with or without a vpn)

@erkme73 I don’t normally use dslreports for speedtest. What button do you press to get results, I’m getting this in Chrome/Brave:

Does disabling shields help? (or specifically ads/trackers in shields)

i get that same but when i tried to use the link that offered in that error


which the http version of the test it work but i did not get the alien thing
i used the dsl test

hope that help and have a nice day

I can see the issue, but unsure what dslreports is actually checking.

Sent a tweet, https://twitter.com/fanboynz/status/1321224074241044480

Have rolled out a fix into shields for this “alien script” warning, give it 24-48hrs. It seems to be based on tracking/fingerprinting the user.

Wow! Thanks guys. What took so long :wink: Much appreciated, and good to know I don’t have some nefarious actor causing the warning.

Yeah, its the “Warning” message is just them. Not Brave, we just limit access to their tracking/scanning abilities.