After KB4023057 Windows 10 update, Brave crashes, won't download files, displays blank webpages, won't close properly

Edit 2: I’ve resolved the issue by just reinstalling Windows. I’m going to chalk it up to a bad system update. sfc /scannow found corrupted system files that I could not repair after numerous attempts. After doing a clean install of Windows (with the same updates as before) Brave now works fine.

Ever since I installed the KB4023057 update for Windows 10 I’ve encountered some strange and frustrating issues with Brave. My current Windows 10 version is 10.0.19041 Build 19041. I never experienced any of these issues with Brave prior to installing this Windows update. I have attempted resetting Brave’s settings and doing a complete uninstall + clean reinstall of Brave with no luck. The issues are:

  • Brave will randomly crash, regardless of how many tabs I have open. I’ve seen it crash less than a minute after re-opening from a previous crash and just opening a tab for a Google search. Other times it can stay open for several hours without crashing.

  • After Brave has been running for a few minutes (~15 mins), it will no longer download files properly. Attempting to download any file won’t bring up the Save As prompt. There’s no indication that a download has started at all, until I attempt to close Brave, where it will warn me that there is a download in progress. The file being download does not appear in the downloads list.

  • After Windows turns off my display due to inactivity, when I return to my computer and activate the displays (I have two monitors, one 4k 60hz and one 1440p 144hz, extended display), Brave will not display webpages properly. There is no page load error displayed, all tabs just display a blank white page and opening any new tabs or going to a different webpage also results in a blank white page. It happens with about 75% consistency after returning to my computer after the monitors have gone dark.

  • Brave no longer closes properly. Two Brave processes remain running in the Task Manager long after I’ve closed the broswer. If Brave was encountering one of the above issues, re-opening it without forcibly terminating these processes will result in brave encountering the same issues again (blank pages, can’t download anything). Only after forcibly terminating the Brave process and relaunching Brave do the above issues get temporarily resolved.

How can this issue be reproduced?

  1. Blank Webpages: Run Brave on a 2-monitor extended display setup. Allow Windows to initialize the screensaver then turn off the display (my settings are 10 minutes for screensaver, 15 minutes to turn off display). Reactivate the displays.

  2. Unable to download files: Allow Brave to run for ~15 minutes, then attempt to download any file. No download prompt appears and no file is listed in the active downloads, but Brave will warn of downloads in progress if the Browser is closed.

Expected result: Brave runs without crashing, downloads files, and displays webpages properly

Brave Version( check About Brave):
Version 1.19.90 Chromium: 88.0.4324.146 (Official Build) (64-bit)

Additional Information: I have Chrome and Microsoft Edge, and they do not encounter any of these issues. If there are any telemetry logging features I can enable and provide, please let me know and I will update. I’ve attached an image of the download issue:

Edit: I’ve attached images of the white page after inactivity issue and zombie processes