Ads on Youtube even when shields is turned on

Have some test fixes in Expermental list (via brave://adblock, show full list).

Then refresh youtube pages

Not sure if its perfect, but test it out.

I enabled Brave Experimental Adblock List, reloaded Youtube, and I’m still (1) seeing the ads, and (2) not seeing the “Skip Ad” button.

1 Like

I also activated the experimental list and although it still doesn’t block the ads, I do have my ‘skip’ button back.

EDIT: it worked on the first video I watched, but now I again get an unskippable 2 min ad

  • Try restarting the browser; ensure you’re on Brave Experimental Adblock Rules - Version: 1.0.22 in brave://components. (force an update).

  • Then clear cookies for Youtube and relogin (important)

For me , is the same . When i log in the adblock does not come out . If i block the cookies , it appear the youtube like not login.

Not saying to block cookies, just clear them

Okay, will have another test rules in due course (maybe tomorrow) The (new) YT ads aren’t easy

1 Like

Clear cookies , update rules and use new rules . Those i have try and the result is the same . Currently only the method , is do not login the youtube , the ads will not come up. If you login in , no ads skip for brave browser, and it will come with ads .

QUCKFIX / temporary solution
I found that If you click at timestamp link that leads to time longer that ad for example 5:00 if ad is 3 minutes long it will turn off the ad.
So I just comment 5:00 under the video, click it and no more unskippable ads.

1 Like

Hi Brave devs.
Same problem here. Just a couple of days ago, Brave stopped blocking ads on Youtube and no matter what I do (deleting cache or temporary files, restarting computer or even installing other extra adBlocker extensions for Brave) it doesn’t block them anymore.
Brave is up-to-date even having updated using the brave://components/ section of the browser.
The Skip button within the ads shows randomly, sometimes it shows up, sometimes not.

My Brave version is:
Desktop Version 1.66.118 Chromium: 125.0.6422.147 (Official Build) (x86_64)
iMac (Retina 5K, 27-inch, Late 2014) Mac OS BigSur 11.7.10

Thank you for your time and dedication.

It doesn’t work and now the videos are loading forever and I don’t know why since that wasn’t happening either after those annoying ads stopped appearing

Thank you for clarification -

Could you tell us how we go about enabling Brave Experimental Adblock Rules - Version: 1.0.22 through the web browser? I’ve looked through brave://components and was unable to spot it.

Youtube should be fixed, update brave://components Brave Ad Block Updater - Version: 1.0.6213 or better

It’s no use, now all videos remain loading forever whenever I try to watch one and I have to disable the ad blocker to make the videos work forcing me to watch ads, I don’t know what’s wrong with the ad blocker since the videos are not playing anymore and they’re now loading in an endless loop

1 Like

did you update to the latest Brave Ad Block Updater in brave://components ?

Yes, but it’s not working at all, why is this bug now happening?

1 Like


I’m still experiencing some interruptions and showing ads on YouTube while my Adblock shields are on.
I tried updating everything on the brave://components, but nothing worked on the YouTube adblock. You still working on fixing the Brave Shields on YouTube?

nope. updated everything. signed out. relaunched browser. still happening…

if you’re logged into a youtube account, you’re seeing ads. all the ads. no option to skip. forced to watch the whole damn thing.

Is it working? (ads should show currently unfortantly)

I tested a few videos on YouTube and I don’t see any ads, would it be because Im on brave nightly?

BTW, Im not logged into youtube

Some users will still see ads, regardless of Brave builds. Its a selective roll out by Google/Youtube.

1 Like