Ads now come on YouTube in Brave

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Whenever I click on any video in YouTube it has now started giving ads first. This problem has been coming recently and a lot of ads including the banners are now coming on YouTube.

Website - https://www.youtube.com/

https://www.youtube.com/watch?v=fM2UXs49y7o (Video in Screenshot)




[And there you have a pre roll ad on YouTube to promise no pre-roll ad in brave browser itself!]

Following Answers as per the given template-

Yes

Yes

No

Yes

Version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Hey @Omg1 I’ve been testing some youtube filters, since youtube have been testing the new ads system. Can you add Fanboy Annoyances via brave://adblock And retest, and let me know?

I’m also getting ads in YouTube nowadays the main reason I’ve started to use Brave to get rid of ads in YouTube.
Now even my social media accounts im using in Brave even the banking sites.
After I’ve ditched chrome, now I’m getting ads in Brave is ridiculous, if the team doesn’t resolve this, I’m sure lot of members don’t have any other options, ONLY TO LEAVE.

Hope you guys, solve this.

Uploaded a possible fix for youtube, give it 24-48hrs.

Also follow my directions above in this message thread, see if they help

No the problem still persists. I have enabled the Fanboy Annoyances List via brave://adblock but YouTube still shows pre roll ads and banners…

And as of 17:30 IST the problem is still there with me…

Interesting the cosmetics aren’t hidden, I would test in private window mode/or even a new Brave profile.

Umm… I have not tried it much but I guess it still blocks YouTube pre roll ads and banners in Private Window but actually sometimes it is not always possible to open a private window ,log in and then watch any video… The ads still come in the normal window in all forms on YouTube…

Try Brave Beta, no extensions, under a new profile? How does youtube look?

No nothing works… I did it with no extensions and a new profile in Brave Beta… It worked in the starting but now this does not work in this situation as well.

Have you tried Strict Fingerprint Blocking, so far this works for me on Android.

Applicable to also Brave, my advice to another user having issues with youtube. Applicable to Brave, my advice to another user having issues with youtube. @Omg1 . Which worked for them. Fanboy Annoyances is available via brave://adblock

So far so good, thank you for the tip!

Tried with Aggressive setting for tracker and ad block under the brave icon for YouTube but it didn’t work either. In Brave Beta though it works sometimes but still I get a little bit of ads on it…

This is the first time I seen 3 ads in a span of 8 to 10 mins playing on YouTube videos and ads on the YouTube page. The reason I move to brave form chrome is to avoid these ads.
Is there something I can do or change the settings to avoid these ads?

Hey, Just follow the directions of the reddit link, do each step. @Omg1 @NightOwl

Have a few people already confirming its working.

Thanks @fanboynz. I seen no ads until now. Seems to work until now.

The method worked for a few days but now again ads come… I have tried all of the settings and changes discussed on reddit and this topic in brave beta as well and it worked pretty well for a few days but now ads come again…
For reference check the screenshot attached…

After I saw the first ad, I did all of the process once again which is mentioned in reddit (the link in this discussion).
But still got ad as in the screenshot below

@Omg1 Can you try again, but clearing clear the cookies, cache in brave://settings/clearBrowserData and then, the following:

brave://net-internals/#dns → Clear host cache
brave://net-internals/#sockets → Select Close idle sockets, and click Flush socket pool

Done it… No ads for now… but not tried much…

Let’s wait for a few days as last time also it worked but for only few days…

I hope this works well… Fingers crossed…

i sometimes see some ads on youtube but when i reload the page, it disappear

Brave definitely needs to improve its adblocker for sure.