Adobe Flash / Google Widevine Support Issue

windows
bug

#1

Okay so I had an issue and posted about this recently in this forum about my adobe flash player not being able to run on flash content from various websites.

As a little background behind this issue, I have an amazon prime membership which allows me to watch prime videos and various other things that I won’t mention here and here is where Google Widevine Support comes in. Amazon Prime Video is DRM protected so Google Widevine Support needs to be enabled for Prime Video to work otherwise it pops up a notification saying that it has to be enabled and therefore will not play the video I am watching. Now I also have a subscription to Crunchyroll Premium which has its own media platform for anime and japanese drama tv shows. This website does not have DRM protection therefore Google Widevine Support is not needed here, however Adobe Flash is required on this website.

Here is what the issue is:
When I watch crunchyroll content, I have to disable Google Widevine Support in the browser to be able to get Adobe Flash to run, otherwise Adobe Flash is not detected on the browser. When I watch Prime Video on Amazon, I have to reenable Google Widevine Support. There is apparently a conflict between these two plugins where google widevine somehow overrides Adobe Flash on non-drm protected sites using flash content. I have tested this numerous times over serveral weeks and I keep replicating this issue. Is there an easier solution to this problem rather than toggling Google Widevine Support all the time when switching back and forth between these two services?

I hope this is detailed enough, if more information is required, please let me know.


#2

Thanks for the report @Runingun.

cc @kamil @sriram and @LaurenWags.


#3

As it stands right now, it’s not really that big of an issue. It’s more of a nuisance than anything. If anyone else is having a similar issue like this, I’m sure this workaround will be at least useful if not anything else.


#4

@Runingun. Do you have site settings to be removed when you close browser? You can follow these steps and check

  1. Go to about:preferences#security and clear everything that is listed under Run Google Widevine
    image
  2. Disable Google Widevine Support in about:preferences#plugins
  3. Visit primevideo.com and check Remember this decision and click apply
  4. Visit Crunchyroll, if you see a similar notification select Remember this decision and click deny

#5

Okay I cleared security on Google Widevine for primevideo.com and then disabled the plugin. I went to primevideo.com and when it loaded it gave me this as a popup window:

ScreenShot_20180507234238

what do I do from this point?


#6

You can click Install and Allow so when ever you visit primevideo it plays. Now visit Crunchyroll and if it asks for widevine permission check the remember decision box and click deny and that should fix the problem


#7

Okay so I did what you said, I clicked Install and Allow, I then went to Crunchyroll.com and loaded a video just fine while Google Widevine was enabled (Google Widevine enabled itself after clicking Install and Allow from that popup window I showed you earlier) then I restarted the browser, Now it’s back to crunchyroll not loading videos anymore. It’s showing what it used to show before anything was done.

Note: I’ve already tried using the link given on the page to install the flash player using PPAPI Opera/Chromium but still the same issue.

Here’s the settings in about:preferences#security
(I would post a screenshot but I’ve already reached my limit of 1 screenshot)

Location access(Clear all)
https://www.google.com: Always deny
Open external applications(Clear all)
magnet: URLs: Always allow
Run Adobe Flash Player(Clear all)
http://www.crunchyroll.com: Allow until ⁨5/16/2018, 4:41:29 PM⁩

And about:preferences#plugins
(I would post a screenshot but I’ve already reached my limit of 1 screenshot)

  • Enable Adobe Flash Support is checked
  • Enable Google Widevine Support is checked

Now if I disable Google widevine, it works just fine like i said in OP, but I’m trying to figure a way around this.


#8

Sorry for the delayed response. I noticed similar issue on another site. It seems to be a compatibility issue. I have logged an issue for this and can be tracked here


#9

well hopefully somebody can figure this nonsense out, we’ll see what happens. If anyone happens to find another workaround besides toggling Google Winevine all the time, post it here please and thank you. I’ll keep my eyes peeled for anymore replies to this topic.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.