Address Bar "Press Tab to Search" starts searching on space with Google

Description of the issue:
When typing in the address bar, typing “google” followed by a space automatically jumps to search term entry mode. The address bar still says “Press Tab to Search”, and pressing tab works as normal, but pressing space also enters search mode. The expected reaction would be for a space to be typed. An example usage is if I’m searching for something related to google, as in “google location history”. Google is currently set to my default search engine, and will be used for searches from the address bar that don’t specify a search engine. But with this, if the first word of my search term is google, I have to type it twice: “google google location history” (the first “google” + space will trigger search mode, then I need to type the full search query).

Steps to Reproduce (add as many as necessary):

  1. Open a new tab
  2. Type "google " into the address bar
  3. Address bar enters search mode with the search engine being Google rather than simply typing

Actual Result (gifs and screenshots are welcome!):
Type “google”

Type " " (space, not tab)

Expected result:
Address bar simply displays "google " rather than entering search mode. Search mode should only be entered if the tab key is pressed (as the hint text says).

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):
Microsoft Windows 10 Enterprise Version 10.0.18362 Build 18362
Brave Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:
I’m unsure when this started happening, but I have only noticed it in the last week. Chrome does not seem to do this, only Brave. It happens on multiple Windows computers. Not observed on Android, unable to test a Mac or Linux machine to see.

1 Like

Thanks for reaching out to us – interesting issue On my end, I’m unable to get the quick search option using [space]:

Can you test this with other search engines?

@bjg222 can you share a screenshot for your brave://settings/searchEngines ?

space is used to select (different) search engine using “keyword”. Looks like your keyword for Google is “google”.

1 Like

@Mattches it only does this with Google, none of my other registered search engines do, though tab still works with all of them

@eljuno I’ll post the image later today when I get home

Yes, it looks like “google” is the keyword for Google search, whereas all the auto added ones use the full website name. I’ve confirmed that, for example, typing " " (not the space) also activates search mode, similarly to typing "google ".

1 Like

I’ve changed the keyword for Google search to “”, to match the format of the others, and the behavior is now consistent and as I’d expected above. Thanks for the help!


Awesome @bjg222! I’m glad it’s now solved. :slight_smile:

Closing this thread for now. Feel free to open a new one if you encounter another issue. Thanks for using Brave.

1 Like