Address bar lag


#1

Hello,

I’m using Brave on Windows 7 64 bit. The problem I’m having is excessive lag when typing into the address bar. It seems like maybe it’s doing real time auto complete through google or something to guess what I want? I don’t know if it’s actually doing that, just a guess on my part. Either way, I’ve actually been using Internet Explorer lately just because when I think of opening Brave and I just need to look something up quickly, I get demoralized simply anticipating having to fight with that lag. Typing my string, realizing the typo a few seconds later due to lack of real-time echo of the string you’re typing, then each backspace changes the string, and gives a new burst of lag. It’s just awful.

How do I fix or disable this? Thanks.


#2

Hi @Cronyx,

For disable autocomplete you can go to Preferences > Search.

Thanks, :slight_smile:


#3

That didn’t seem to work. I unchecked:
“Show tab matches”
“Show history matches”
“Show bookmark matches”
"Autocomplete search terms as you type"
and it’s still laggy as hell when I type in the address bar. What can I
try next?


#4

Hi, just to make sure. Are you importing a large number of bookmarks? Because there’s an open issue related to this.


History does not include all visited URLs
#5

Here’s a video of the behavior I’m experiencing. (Typing one handed because holding phone; it’s even more exacerbated when I’m typing with both hands. I typically get 10 to 15 seconds ahead of render speed.)

And here are my search settings.

So much delay in typing a URL is completely unacceptable, even compared to Netscape on Windows 3.1. It makes any kind of workflow or usability impossible.


#6

cc @sriram for additional help.


#7

Is that something I need to do, or is this like reddit, where if you mention the user like you did with a hyperlink, they’re summoned?


#8

Ah, I’m just mention him for additional answer. I’m only contributor – non-tech – and he can help because he’s one of Brave team. :slight_smile:

I’m sorry for the confusion. :lion_face:


#9

Hello there.

From your post I couldn’t tell whether this problem occurred recently or has always been present. I know it’s a bit of a pain, but perhaps a clean install could solve your problem. You can find the instructions here:

Just in case it doesn’t work and you quickly need to get your bookmarks back, you might want to move the folders in %appdata% rather than delete them.

You can move them back after reinstalling and having determined a clean install is not the solution. Who knows, maybe if it solves the problem and you move the files back your problem remains solved. In the worst case if the problem returns, you’ll have to do a clean install again.

I know a clean install isn’t ideal and perhaps it doesn’t even help, but it would probably help narrow down where the problem is.


#10

@Cronyx I see you have a lot of tabs opened. I believe you have set 20 tabs per tabset. Could you let me know how many tabsets are opened when you face this issue? Do you also see the same lag when you have just one tab opened? If you have important pages opened in all tabs, request you to kindly follow the steps mentioned by @Degine or follow the steps mentioned here How to backup Bookmarks and settings and create a new profile with just one tab and check if the lag still persists?

@Degine Thanks for the post on backup and new profile creation.


#11

I don’t really have that many tabs open, by the right comparison.

Steve Gibson of the Security Now podcast (episode 492) explains how he has over 200 tabs open routinely, many of them over a year old, for various ongoing projects.

I don’t know if that goes to the right time index (6m:20s), but here’s a transcript:

I’m still, until Chrome solves the tabs problem, I am still over on Firefox. And actually the footprint problem, when I launch Chrome, it just gobbles memory compared to Firefox. So I’m still there, over on Firefox, and happy with 200 and some-odd tabs open. So, yeah, I sort of use it as my messy bedroom of stuff that I want to get to. I have tabs open from reference material that I was using when working on SpinRite 6.1, so that gives you a sense for, you know, SQRL took over, and we’re now like at T plus 15 months of the SQRL project. So those are dusty tabs, but Firefox is holding them open and knowing that I’m going to get back to them soon as I get SQRL wrapped.

In a later episode which I can’t find a link for, he remarks how it had ballooned with a few new projects to over 600 tabs.

I’m a power user and my workflow tends to similarly necessitate high tab usage. Is this the incorrect browser to use if I require a large number of tabs?

I’ve browsed through all the settings, both in about:preferences and in the “alt ribbon”, and I can’t find where to create a new profile like you do in Firefox or Opera. Could you point me in the right direction?

I did however try opening a new window with only one tab open, and observed no change in behavior.


#12

I am having the same problem and I am running the Mac version. It seemed to start with a recent update (0.15.0?). I don’t have a lot of bookmarks, certainly no more than I had with previous versions of Brave. I also notice screen sluggishness when scrolling.

I am going to try doing a clean install and see if it resolves.


#13

Thanks @square.wave, please report back anything you find.


#14

@Cronyx

If I purge the browsing history, the address bar lag goes away for a while. About 2 days worth of browsing is enough to make it laggy again.


#15

Ok. Then it sounds like what’s happening is, the browser is real time match
searching your history with every string update; which is to say, every key
press. I have the search settings turned off that do that, but the
browser is ignoring those settings. Devs, can you confirm this is the issue
please?


#16

Same problem here thanks. Sometimes also gets stuck with about:blank in address bar which does not auto erase on mouse select


#17

Just to pile on, I don’t have many tabs open, I don’t have many Favorites, and the lag/“Not Responding” error is making me rethink my use of Brave. It’s just not acceptable in 2017.


#18

we’re trying to fix the performance issue. it’ll be fixed before we reach 1.0


#19

I just installed, late October 2017. Same problem, search brought me here.

Toggling various combo’s in search preferences, I found “show history matches” to be the ONLY feature causing the lag. All the other options turned on works fine. That’s what fixed it for me. ymmv.


#20

Search brought me here. Issue still not fixed. I have to disable ‘Show History Matches’ to make the browser useable again.
Please improve history search speed.