Additional brave windows freeze up

Brave version 1.15.72 installed on Ubuntu 18.04.5, gnome shell 3.28.4

I have a fresh installation of Brave, with no extensions installed.

When I start Brave, it works fine.

If I then open a second Brave window - not a second tab, but a second window - that second Brave window is “frozen”: I cannot type text into the URL bar, none of the links on the page are “clickable”.

Restarting Brave, restarting the computer do not help with this problem.

I do not have this problem with other browsers (chromium, Google Chrome).

Why does Brave not work correctly?

What is causing this problem?

How to I fix this?


Did you install Brave using the Ubuntu apt repository … or did you download the Brave .deb package and install manually?

Try this … using a GUI task manager or “ps” at a command line, fire up Brave … make note of the PID of this first window.

Now open a second Brave window, then make a note of the PID of this second process (window).

Attempt to close the second window - does it close?

If no, use the task manager to kill the second window process … or at the command line, use kill to terminate the second window’s PID.
NOTE: I’m not implying this is how you should close the window, just ensuring it disappears.

One other question … have you checked logs to see if Brave is reporting an issue closing the second window?

1 Like

I can confirm this issue with the Brave-Browser (1.15.72) on my system: Debian 10.6 with AwesomeWM. Every new windows, installed PWA or opened shortcut does not render and is stuck/frozen.
It seems some hardware accelaration may broken because youtube in fullscreen does also not respond correctly.

1 Like

It seems it’s really related to the hardware acceleration. If you disable the hardware acceleration (–disable-gpu) as a workaround the issue is gone, but 3D content too.

I have six different machines and do not have the issue (all have hardware acceleration enabled).

For most folks, turning off H/W accel only works in about 20-30% of the cases (such as yourself … not saying it won’t work for this user).

It’s my experience that disabling H/W acceleration is related to something amiss with the H/W specs of the machine, such as a minimal spec’d machine.

Something to keep in mind is that the hardware acceleration option is baked into the Chromium base, so is not a feature specific to Brave.

Linux Mint cinnamon
Version 1.15.72 Chromium: 86.0.4240.75 (Official Build) (64-bit)

First window opens and works fine regardless of how many tabs I open.
Second window (regular, private and TOR) all are almost unresponsive. Clicking on buttons within the web page seem to work OK but typing in the address bar is useless. Videos are choppy.
Dragging a tab from the first open working window to make a new window recreates the problem.
After opening the second window, closing the first working one does not alleviate the problem.

Yes, but chromium/chrome works correctly. So I think it is somehow related to Issue #11504 which is mentioned in the release notes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.