Adblock not blocking ads - can someone please help and give me example blocked URL/image format?


#1

I am new to Brave. I have tried adding entries to the Adblock box but those ads are not being blocked on the designated website. I use Adblock with another browser and copied entries, so they SHOULD be in the correct format. Is there anyone who can PLEASE help me out? Thank you very much in advance.


#2

Hi @UK88TL can you please provide a URL for us to review, and a screenshot of the ads you’re seeing if possible.

Can you also let us know your geo-region?

Thanks


#3

Is this thread private? I don’t want to be posting embarrassing data in public! HAHA :blush:
What do you mean by geo-region? I am in Fort Lauderdale FL.


#4

An example IMAGE URL which I am trying to block would be: https://ad03.adam4adam.com/adverts/60b7c6fad73b6fdd9a1b8ec9a4ec0960.png (I would like to block EVERYTHING from that “adam4adam.com/adverts” location.


#5

This thread isn’t private! :wink:

Fort Lauderdale, FL works for the location (making sure that this wasn’t a regional blocklist issue)

I basically just need to know what domain the ads are observed on (doesn’t have to be the exact same URL, just the site), so I can investigate and see what ads are serving past the ad blocking.

Thanks!


#6

Any updates? :heart:


#7

I am planning on looking at this more closely today, but am still a little unclear as to which website this issue is occurring on.

I see that a4a is the advertiser that you’re looking to block, but I don’t know if the a4a site is where the ads are showing up, or if you are seeing a4a ads on other sites.

If a4a ads are showing on the a4a site, the blocking is handled differently than if the a4a ad is seen on a site other than a4a.

Thanks!


#8

Look above. Yesterday I sent a URL and the main website address is in it…


#9

Got it. So the a4a-hosted ads on a4a.com. Thanks for clarifying.

I will investigate and follow up.


#10

Any updates? :persevere:


#11

Hi @UK88TL,

I have investigated, and can explain why the custom filter approach you attempted via about:adblock was not functioning as you’d expected it to.

By default, Brave blocks ads and 3rd party tracking, but in this particular case with the a4a site, the ad you linked to and the path are on the same domain as the actual website.

These are considered 1st party, or site-served ads, which are used by publishers for promotional purposes.

With the ad living on the same domain that the website lives on, Brave sees the ad as a static image, just like the other images that display on the site.

As far as threats for these types of ads go, they are the least likely to cause harm to both the Publisher and the end User.

We totally understand that at face value, this appears to be no different than 3rd party ads, and would be something that users would like to block in some cases, so we have created a feature request to allow for right clicking to hide 1st party ads from the page.

You can track progress for the issue here:

https://github.com/brave/browser-laptop/issues/7521

This may not be resolved immediately, but this is an item we definitely have in queue.

To be safe, I also ran some additional checks on the website in question to make sure that we are currently blocking 3rd party ads and tracking as expected, and can confirm that Brave is blocking those ads and tracking as expected.

If you have any questions, please let me know. I am happy to help answer any as needed, or take a look if any non-1st party ads and tracking are observed.

You can also check the Shields Panel (lion icon) and click on the Ads Blocked count to get a breakout of the ads that have been blocked for the webpage you are currently visiting.

Thanks,
Luke


#12

Thank you very much! How do I follow #7531 and receive email updates on it?


#13

No problem @UK88TL!
If you sign up for github (it’s free), you can click on the link to that issue and click the Subscribe button on that issue on the right side of the screen. The screenshot below shows where the button is on the issue page:


#14

Hi Luke. May I please ask you another functional question related to something not working correctly on the A4A site?


#15

Hi @UK88TL, feel free.

I would first recommend comparing functionality between Chrome and Brave to ensure it is not something specific to Brave (if it is not specific to Brave, site support would be the route).

That said, if you already did that and it is something functional that is only happening in Brave please do let us know and we can investigate.


#16

It is specific to Brave. ON the a4a site when you click on a user’s photo (which is in essence a thumbnail version) it is supposed to open a window with a full view of that photo. However with Brave it opens a new popup window but no photo displays. It opens a new window with “about:blank” showing in the URL field, and the TAB names displays “Untitled” with a spinning circle icon that just keeps spinning. No full-version of the photo displays.


#17


#18

Thanks, @UK88TL will investigate and open an issue in GitHub if one doesn’t exist, or add to a relevant issue if one does. Should probably have an update on Monday, but you may want to try disabling Shield settings for the site in the short term from the lion menu to see if that temporarily resolves.


#19

I tried Shields DOWN but that does not fix it. Can you please add me to the new issue so that I get email updates? Thank you so much for all of your help. You’ve been terrific!


#20

Thanks @UK88TL - I ran out of time to investigate this today, but will look into this tomorrow and follow up.