Ad-Blocker Detected even with Shields Down

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

  1. Go to
  2. With Shields Down, Ad-Blocker is still detected

Expected result: Not to see Ad-Blocker detected.

Brave Version( check About Brave): Version 1.53.71

Additional Information:

I don’t see the adblock popup on the site, and I have my shields set to aggressive, do you have a specific url or screenshot

What’s strange is that I didn’t use to have this issue … just in the past week or so.

Setting my shields to Aggressively block trackers and ads seemed to fix it, but also try aggressively block fingerprinting

You can also go to Settings > Shields > Content filtering > and enable these lists

I’m not seeing the issue after doing this, let me know if it works for you

OK, thanks … I’ll play around with this and see what happens.

If you are using a DNS server that is filtered with some adblocking list, disable it, or use an unfiltered DNS from the list in brave://settings/security

If you disabled Shields, nothing should get detected, ‘Adblocker detection’ is not detecting extensions or anything or adblockers or anything, it is only detecting what adblockers do, like changing the css of an html element to display: none !important or blocking a script, so if it is off, there should be no detection at all.
There is a feature uBlock has and Brave adopted that can redirect scripts so they don’t get blocked and they cheat the pages thinking they are getting the file to avoid detection.

The problem is DNS servers with some ‘adblocking’ capability can interfere with $redirect or $redirect-rule so you should test that first.

Saying that, I didn’t see any ‘adblocking’ detection, and obviously you shouldn’t have seen it with the the adblocker set to off.

Also, you need to provide screenshots next time, to make it easier to know like devtools, console, Brave shields panel, the detection message, etc, to make it easier to see what it could be the issue.

You should also try disabling all extensions or testing in Private Window to see if you see the same problem, it could be an installed extension the problem as well.

Fanboy Annoyances already include all the other Cookie Social, Newsletter easylist/fanboy lists you enabled so you are adding duplicates you don’t have to.

1 Like

I am running thru OpenDNS, however, nothing is set to be blocked. Thanks for all the info, I’ll keep messing with it and see what happens.

A post was split to a new topic: Tokuzilla: Adblock detected

Fixes incoming to Brave Nightly (allowing some cosmetics in standard mode)

Add the following into brave://adblock > .fixed[class*="adBlock"][class*="overlay_overlay"][data-test="ad-slot-visible"], offsetHeight)

Thanks so much! Afraid I’m going to need a little assistance with how/where to add this…Thanks!!

1 Like

Could I get a brief tutorial on how to add the above info? Thanks!

Enter brave://adblock in the address bar
Scroll down to Create custom filters section and copy/paste that list above on a new line.

1 Like

OH, Ok … Thank you very much!!

Well, it works great for “”, but not on the actual page I was needing/wanting, “”. I thought I could skip a line and paste the same thing again but this time adding the “/commodities/real-time-futures” part … but in looking at the code, guess it’s specific to the home page … that correct? Hate to bother @fanboynz again, but could I get what it takes for this other page? Thanks so much!!

P.S. - I see I didn’t post the full link in my original post (did in my second) … sorry about that!

Add these to the existing filters in brave://adblock:
1 Like

Thanks … but for some reason, I’m still getting the message on that page. :thinking:

Works for me. Should look something like this:

1 Like

Mighty strange … that’s exactly what I’ve got.

Well, even though “” started working with the Shields still down, when I brought the Shields back up on this other page, it started working … guess that makes sense, I guess. Regardless, thanks so much for your time and the solution!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.