About the 'new' BlockFi new tab popup... 👎

Since Nightly 1.6.36 I have been receiving this little obtrusion in my browser.

image

Please do not let this pass Nightly, let alone into Dev or Stable. It’s super unsightly and distracting. I like the Windows 10 Notification integration better personally.
And to my recollection, Brave does not own BlockFi, nor is BlockFi even Brave certified on their site. Nor am I getting paid BAT for this popup-ad.

Please do not take this as me being spasmodic, as it’s more of Nightly ‘feedback’ let’s call it. But this is just downright annoying and awful. This is the reason WHY I switched to Brave was garbage like this… Was to evade the popup system. This classifies as a popup to many.

EDIT: I can confirm on my work console, VM as well as my main machine (All Win 10) that these appear with Brave ads enabled or disabled, see screencap below.

Comments from Devs /Brave Team members would be highly appreciated, but not required.

REFRENCES


-AASB

1 Like

@AsAboveSoBelow If you don’t want to see sponsored images, you can disable them from the Dashboard Settings and when turned off, you won’t be able to see all the sponsored images.

2 Likes

Feature does not work. Have clicked that button that appears over Brave ad rewards. They should have tested this in Nightly before dropping this across the spectrum like that. I’m really not the only person who outright dislikes this feature.

1 Like

That’s weird. That feature works on my PC. When I disable the sponsored image, those pictures sponsored by BlockFi never shows.

Where I can find that option?

I would like to disable sponsored images. I don’t like this type of spam.

Thanks.

@xitopodo At the bottom right of the browser when you create new tab. There are 4 icons there; dashboard settings, preference, bookmark settings and history.

3 Likes

image

This is what I saw and clicked personally. Didn’t know that tickbox option was there, but sadly, checking it to off and restarting brave immediately has it come back on the next boot of the browser.

Something similar does occur with shields and not being able to set it to block all device recognition attempts.

Will ref later.

-AASB

Here’s a question, how do you turn it off on Android? If I can’t, I’ll end up donating my BAT and remigrate to FF. Cause it’s even worse on mobile.

@AsAboveSoBelow If you want to disable Sponsored Image on android. Open Brave Browser -> open the menu ( the 3 dots usually at the bottom right of the screen ) -> Settings -> New Tab Page, then just disable sponsored image.

1 Like

Thank you so much! That alleviates that…Now as for Windows…This needs a fix. It happens on a virgin Windows install VM on Nightly. So I can confirm that this fix sadly does not work in a fresh environment on my end either…very strange.

Maybe the Nightly build is the problem? Why don’t you try it on the normal release of Brave Browser just to be sure. If can disable the sponsored images on the normal release of Brave, then that would mean that the Nightly build is the problem.

1 Like

@AsAboveSoBelow,
I’ve just tested this on my Windows machine and the toggle seems to be working just fine. Use the Show Brave Rewards toggle to switch the Rewards widget on/off. Use the Show sponsored images option to toggle off NTP background ads:

@Mattches was this nightly? I can try and upload some footage later when I get a free bit at my PC, I’m on my mobile rn.
EDIT: Is it possible Brave clearing cookies and data on exit would affect this? I like mine setup that way and I use the exact same settings config on my work/vm/main enviros.

My Brave Browser is setup that way as well. It clears everything on exit. But with your situation, it sounds similar to the restore to previous version function of Windows. Reminds me of the DeepFreeze app that restores everything back to when you setup DeepFreeze every time you restart the OS.

@AsAboveSoBelow,
:point_up: The above was not in Nightly, no. However, I went ahead and tested on my end in Nightly just to make sure I wasn’t giving bad info – seems to check out. All options worked without issue. Observe the gif below:

2 Likes

I think his problem is not the browser itself but how the browser was set up in his Windows VM or how his Windows VM was set up. He mentioned that he was able to disable the sponsored images but every time he closes the browser and opens it again, it reverts to the previous setting where sponsored images are still enabled.

My guess is that it has something to do with how he has setup his Windows on VM.

1 Like

Or something to do with my specific config of settings. Or just maybe something entirely local that I might be overlooking. This very well may be a localized issue.

Why don’t you try making another fresh Windows VM from scratch and install only the Brave Nightly. If it all works out then that would mean the problem has to do with how you created your previous Windows VM.

I’ll end up trying it without my settings first, and if needed after that, THEN setup my sandbox next.
Thank you all for the help so far.

1 Like

@TeotiX thanks for pointing that out – got too wrapped up in making that gif that I completely forgot about that part! This is likely the case, but I’d like to know what you find out @AsAboveSoBelow – please keep us updated :slight_smile:

2 Likes