About:bookmarks; searchbox not working in the bookmarks manager on macOS


#1

hello in the bookmarks manager; about:bookmarks, when I want to type something in the bookmarks searchbox on the above right next to the import and export stars, nothing happens , cannot type anything in there, hope it will be fixed thx , this is the latest version of brave :

Brave 0.23.39
V8 6.7.288.46
rev 3ee14b0
Muon 7.1.6
OS Release 17.7.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 67.0.3396.103

Bookmark search field does not work
Ability to Search Bookmarks
#2

As this is a known issue I’ll go ahead and +1 it so the team can address it appropriately.

Thank you for supporting Brave :slight_smile:


#3

#4

#5

Reopen this thread. :smiley:

@Mattches, I believe that’s different issue with report from @bwave. He talked about bookmarks search box at Bookmarks Manager (Ctrl+Shif+O) that not working.

image

I can confirm this issue on my laptop. It not registered any letter that I typed. :slightly_smiling_face:


#6

@eljuno, great catch! :clap: The github issue was strikingly similar, especially with the title :sweat_smile:

This is interesting since I cannot seem to reproduce this error on Windows or Linux - Bookmarks search in manager works just fine. I’ll dig around some more and see what I can find if anything. If not I’ll submit a new issue on github.


#7

@Mattches @eljuno thanx a lot, I hope this gets attention now


#8

@Mattches I added a record of this issue. LICEcap not catch it correctly, but you should see the issue.

After searching existing issue, now I remember some users report similar issue in the past. Like Bookmark search field does not work that lead to https://github.com/brave/browser-laptop/issues/13322. The issue closed as fixed, but it seems it’s not fixed for some users. :smile:

And more reports:


#9

Thank you @eljuno for the information. With ubuntu 16.04 LTS I can confirm the same error (gif picture) like from @Mattches.
The Brave install was via information from the brave website via terminal install around 12.2017:
deb [arch=amd64] https://s3-us-west-2.amazonaws.com/brave-apt xenial main

I setup now new my pc and installed ubuntu 18.04 LTS.
I took now the Brave snap directly from the Ubuntu Software center.
With the Brave snap install at ubuntu 18.04 works Brave with the “Search bookmarks” function fine.

Brave 0.23.31
V8 6.7.288.46
rev 3148ace
Muon 7.1.5
OS Release 4.15.0-23-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 67.0.3396.103

Only maybe a suspicion:
Difference gnome terminal ubuntu 18.04 to 16.04 for script bash background processes:

Option “-e” is deprecated and might be removed in a later version of gnome-terminal.#


#10

+1 from @grok via Ability to Search Bookmarks.
+1s via Bookmark search field does not work.


#11

hello unfortunately two updates later it is still the same , I hope this really gets fixed soon, thanx

Brave 0.23.77
V8 6.8.275.24
rev 0125b5f
Muon 8.0.6
OS Release 17.7.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 68.0.3440.84

#12

well it yes it is working on windows 10


#13

As of today, I still have this problem on macOS. I came here looking to see if this was being worked on and found this ticket. The last several updates have not addressed it, it’s been going on for weeks.


#14

Yes indeed , is it really so difficult to fix that?

  1. Aug 2018 19:10 by brave@discoursemail.com:

#15

I also have this problem - on a pc windows 10

I cant type in the Bookmark Manager’s search bar

Brave2


#16

I’m having a similar problem. All my bookmarks disappeared with the exception of the ones on the toolbar and I can only find them by using the Search Window in the Bookmark Manager. They appear to all be there-just not visible. Getting frustrating isn’t it?

Brave: 0.23.105
V8: 6.8.275.24
rev: 9a46f8f5cb22a9daf2af21989aed25911aa6f839
Muon: 8.0.9
OS Release: 17.7.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.84


#17

Hi everyone,
I apologize for the late response on this particular issue. We’ve had several reports after recent updates with about:history and about:bookmarks. The error is likely rooted in the Muon front-end which Brave is run on. As you may know, we are currently very close to fully transitioning away from this build of Brave and into Brave 1.0 which is built with Chromium’s native UI.

While I understand it’s not the answer you want to hear, it’s unlikely that this issue will be resolved before we roll out 1.0. There’s always a chance, but I don’t want to get anyones hopes up. Since we’re so close to the v1.0 release, our dev team has been migrating several issues from our Browser-Laptop Github repository to our Brave-Core repository and trying to parse out what will or won’t be addressed before 1.0.

What I can confirm is that all open “bookmarks” related issues will be fixed in 1.0 - including the topic of this thread (and everything inside). The launch is set to be just a few months from now, with a beta releasing sometime before then. If you’d like to see what we’ve been working on, you can grab a Developer channel release now. Its worth mentioning that the current Dev build is a work in progress - the build is still early, and prone to some stability errors. It’s also not “feature complete”, that is, Brave specific features like, Payments, Tor, Sync, and UI elements still have yet to be added.

Even given that, the build is great and worth at least checking out (I’m using it to write this reply!). You can find it on our releases page. Thank you all for your patience and support. We promise it’ll be worth the wait!