A private connection to patriotemail.net can't be established because your computer's date and time (Thursday, July 22, 2021 at 4:35:09 PM) are incorrect. NET::ERR_CERT_DATE_INVALID

We’re on an I-Mac desktop, running OS Catalina 10.15.7…most current. When going to a site I’ve checked often, I now get a message from Brave saying you can’t connect to that site because my time and date are incorrect in the computer. But they are not wrong. We live in north Idaho which is pacific time, not Mountain.


Description of the issue:
How can this issue be reproduced?

1.Getting message saying site can’t be reached because you can’t connect with my time and date not being correct. But they are correct. We live in north Idaho. We are pacific time, not mountain time.
2.
3.

Expected result:

Brave Version( check About Brave): version 1.26.77

Additional Information:

It’s a known bug, developers are trying to figure out a fix:

You could try the workarounds described in the article below until developers fix the issue:

1 Like

Thanks for letting me know that others have this problem too. The workaround doesn’t apply
to my problem though. Guess I’ll just have to hope they find a fix and someday mine will start
working right again.

(Attachment pastedGraphic.tiff is missing)

Maybe . . .

Make note of your current Time and Date settings - that is, how you set those in System Preferences.

Then - change to making manual adjustments - and set the time back, by various amounts.

Try 1 minute back. 5 minutes. 30 minutes. 61 minutes.

You might find a time that works. Date is probably OK.

My time and date are set right….why would I want to find another time that might work?!
That does not solve my problem. I can just use safari and reach anyone I want. I prefer Brave,
but not when I can’t get to a website that I can get to easily with safari. This is a new probem for
a long time brave user. I was hoping there was a simple fix.

(Attachment pastedGraphic.tiff is missing)

The error you are experiencing has nothing to do with your date and cloak settings. Brave is displaying a wrong message when a website’s TLS certificate has expired. Hopefully a fix will be committed soon as developers are figuring out a fix.

1 Like

Brave is rejecting my responses to you….says i can’t have my logo on the page, must use
over 20 characters, can’t breath out of my left lung on Friday….thanks for trying to help.

1 Like

It was just a test thing, to see what might happen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.