A page displaying ads (desired ads, not spam) is blank but the links to the ads are active

Description of the issue:
Texas grocery chain HEB posts weekly ads. When I open the web page in Brave, the header fills in, but the ads aren’t there. However, if I hover the cursor over the blank page the ad for a specific item is active and if I click it the ad for that particular item will open.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Launch Brave
Go to https://www.heb.com/weekly-ads/weekly-deals

Actual Result (gifs and screenshots are welcome!):
The way it looks on Brave. The header is there, but the ads are blank.

Expected result:
The way the page looks on Chrome.

Reproduces how often:
Everytime. It has been this way since I installed Brave

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 version 1803 (OS build 17134.885

Brave version 0.66.101 Chromium: 75.0.3770.142 (Official Build) (64-bit)

Additional Information:
The weekly ads for Kroger and Aldi seem to work fine.

@Profrog,
This is because each one of the ads placed has some form of cross-site tracking data attached to it. Brave’s built-in adblock/protection software, Shields, blocks content that requests to send or read data from 3rd party sources.

To solve this, you’ll have to allow ads/tracking for the website in question:

  1. Visit HEB.com
  2. Click the lion icon in the address bar
  3. Toggle the 3rd party trackers option Off

Allow the page to refresh and you should now be able to view the ads as intended:

Mattches,
That fixed it. Thank you so much.
Terry

1 Like

@Profrog,
My pleasure – enjoy! :slight_smile:

Okay landed a fix. (you’ll see update in the next 24-48hrs).