A frustrating problem with ad timers (I think)

I got the Brave browser (latest version: 1.9.72) on my Windows 10 machine since about a week. I do get notifications in general and the notifications are not part of my problem.

My problem is, that I only get an ad shorty after I start up the PC, or after I wake it up after it “snoozed”. After that, during the rest of my day, I do not receive any more ads. Only 1, when I start the PC.

I do believe that there is a problem with a timer not being reset after I receive my first ad, but I do not know how the ad program actually works, so that’s just an assumption.

I do get ads normally on my other win 10 laptop and my phone, so it has nothing to do with my location (France). I tried everything I could find online and it seems to be a problem with how Brave ads are displayed. I would really appreciate if someone from the Brave team that knows how and under which circumstances Brave shows it’s user’s ad’s could contact me so we can find a solution.

Again, I do not have a problem with notifications (those work perfectly), I do not use a VPN, I am in France, I have set ads/hour to maximum (5), I am opted into rewards and into ads (obviously) and I get ads normally on 2 other devices (win10 and android).

It is really frustrating, since it’s only a problem on my main machine, that I use basically all the time. If you are an insider to Brave’s ad program and can contact me, I am more than willing to find out what the problem is and how it can be fixed for myself and many other people in the same boat.

If you have any more questions, I am very happy to tell you everything I know about the issue.

I am thankful for any ideas or possible solutions, so just type your thoughts away into the comments.

Thanks

@schrome,
Thanks for reaching out.
I know that you’re not the only user to encounter this particular issue. I’m not entirely sure what is causing it though. I’ve reached out to some appropriate team members to see if anyone has a solution – in the meantime, ensure you’ve set your focus assist and related settings properly on your machine:

1 Like

Thank you, I hope I can help to resolve this issue and make Brave a little better one step at a time.

1 Like

After talking to the support, the issue was identified to be my mouse.
After unplugging the mouse I received ads normally. The support was very helpful and the mouse I am using was documented to help resolve the issue in future patches. :v: