360 degree videos don't play in brave-browser

360 degree videos don’t play in the browser

How can this issue be reproduced?
Go to Youtube and try to watch a 360 degree video e.g https://www.youtube.com/watch?v=hNAbQYU0wpg

Instead of showing a 360 degree video and being able to navigate around the video with the mouse, it shows a flatten out video.

Videos work in Firefox.

Brave Version( check About Brave):


Additional Information:

OS is Ubuntu 22.04

Brave was installed from the official apt repo following instructions from brave.com (not a flatpak or a snap)

There was a workaround Can't watch 360 videos

But it doesn’t work for me. Turning off the shield doesn’t make any difference.

1 Like

Don’t ever take your shield down , your shield prevents you from being tracked , and stalked by unwanted shady people , that usually lie scam and manipulate ways to get your personal information , so that they can rob or scam you , brave shield protects your privacy

Hello there @kmod please accept my apologies for this issue. Could you please try opening your main profile in private or guest mode to see if the videos play properly? If they do load, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menuOpen Guest window

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

1 Like

Hi, it is working now.

I installed the play-with-mpv extension. I disabled it and 360 degree videos work, strangely I enabled it again now both 360 degree videos and the play-with-mpv extension now both work (though of course 360 degree videos doesn’t work in mpv as expected)


1 Like

@kmod glad to read that, if the extension keeps presenting problems, you could try a new installation for that extension to see if that solves the issue.

If you have other concerns, please let me know or create a new community post so we can further assist you.

Regards :lion:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.