1Password Update to 6.8 does not allow to fill in password and form data into Brave

performance

#1

I have recently updated 1Password and whnever I start my browser it gives me a popup saying that 1Password cannot fill in passwords or form data.
Tried restarting the browser still to no avail.
Then I visited the 1Password website where they said that the browser should support Native messaging.
How to resolve this?


1Password Broken for Brave
#2

The strange thing is, when you open 1Password and fill in your password before opening Brave, everything works as it should!?


#3

nope not happening. It just goes to the website


#4

Me too - no access to Brave extension even if you log in to 1password directly before opening Brave


#5

Hello @arjunreddiar.

Version 6.8 for the Native Messaging issue, will be enabled automatically with the next 1Password extension update. The update doesn’t rely on a HTTP server running at 127.0.0.1.

Try this, if you haven’t already. This should work:

  • Click to install the 1Password Chrome extension in 1Password 6 again. Allow the Beta Extension on the extension download page. Then allow Native Messaging for 1Password browser extension in Settings, Choose Options, Then choose Advanced. After you exit 1Password 6 via the notification area icon, then restarting it, this should have resolved the issue.

#6

I tried it but to no avail.

I have also sent an email to support of 1Password and have received the following reply:

I believe Brave are in the process of updating the copy of our extension that they build directly into their browser. They are currently using an older version that we released back in February of this year, version 4.6.3 and once they update to 4.6.7 everything should work again. Until then though there isn’t anything you or we can do as a temporary workaround, it will require a new Brave to correct. I apologise for the disruption but hopefully it won’t be for long.


#8

Hello @cmadland @arjunreddiar

Okay.
Gotcha.
We’re on it.


#9

+1 from


#10

Hi @arjunreddiar @333 @cmadland,

It should be fixed in latest release. Please update your Brave version.

Thank you,
:slight_smile:


#11

Hey,
Just updated the browser. It is still showing me the same error.


#12

oops. just had to restart my computer and its working like a charm.

Thanks guys :+1:


#13

The latest build should have fixed all of this. Some of you may have to toggle the extension on and off in preferences then restart after updating. I’ll leave this open until Tuesday and if nobody pipes up, I’ll consider it fixed and close the thread.

Thanks!


#14

Same thing is happening to Last Pass. As soon as you open the icon to put in the pwd, the entire dialog bod closes the instant you click it & so you have to go to Last Pass.com to get into your stuff. Happened right after this last update


#15

Hi @DallasVette,

There’s an existing thread related to LastPass. It’s a known issue and under investigation.

Thanks,.
:slight_smile:


#16

Closing the thread as 1Password issue is resolved. For Lastpass please follow the link attached by @eljuno


#17