1Password (6.8.BETA-4) No Longer Works in Brave

bug

#1

This is the 1Password error that comes up every time that I launch Brave http://take.ms/sjZ5j.

My support details http://supportdetails.net/SQMOODFA.

Brave: 0.15.2
rev: af7ef42ad622f899312a38bdd0e2138154393627
Muon: 2.58.9
libchromiumcontent: 58.0.3029.96
V8: 5.8.283.37
Node.js: 7.9.0
Update Channel: dev
os.platform: darwin
os.release: 16.6.0
os.arch: x64

My 1Password version:
1Password 6
Version 6.8.BETA-4 (680004)
AgileBits Beta

I’ve discussed the error with the 1Password team.They responded, "You can’t install the browser extension into Brave using our website. That is why you are getting that error (there is no work around for that). I get the very same error when I do what you did in that video.

Brave takes our extension and ships it with the Brave web browser, so we can’t troubleshoot why it’s not working with their web browser. We have very little to no control over the 1Password browser extension in Brave."

I am guessing that Brave needs to update its 1Password extension that it’s shipping with the browser. Does this sound correct?


#2

Hi @zeb

Could you please update to the latest version of Brave and let us know if this is still an issue?

Thanks,
Lauren


#3

Just updated, same error persists :confused:


#4

@zeb 6.8 is beta. 6.7.1 is production for 1Password. You’ll need to use the production version instead of a pre-release. :slight_smile:


#5

Hey @alex,

1Password 6.8 will be released very soon. @zeb was correct when he said:

I am guessing that Brave needs to update its 1Password extension that it’s shipping with the browser. Does this sound correct?

1Password 6.8 can’t accept a connection from Brave until Brave updates its copy of the 1Password extension to the latest version.

One of our developers reached out via email a little bit ago and hasn’t heard anything back just yet. Hopefully Brave can get that updated ASAP so the transition is seamless for everyone. :slight_smile:


#6

Thanks for following up @1PasswordKhad!

I just got back from vacation today. Was the email from Jamie?

I’ll make sure this is prioritized.

Thanks again!


#7

Yep, that’s the one. Thanks, @alex!


#8

I just wanted to follow up for folks following this thread.

It appears the issue is in progress, and you can track it here:

Thanks to the Brave team for being on top of this. :+1:


#9

This is working for me on Mac OS X 10.12.5

Make sure the 1Password app and your unsupported browser are both in the Applications folder.
In Finder, choose Go > Go to Folder. Copy and paste the following path and press Return:

~/Library/Application Support/Google/Chrome/NativeMessagingHosts/
Copy 2bua8c4s2c.com.agilebits.1password.json to your Desktop.

Choose Go > Go to Folder. Copy and paste the correct path for your browser and press Return:


#10

1password 6.8 no longer beta and Brave is no longer compatible after update to 6.8 (1password). In the link below, they say Brave needs to enable native messaging - or you can try Guuz’s suggestion above - but there still needs to be a fix in the browser.
https://support.1password.com/kb/201707/


#11

The first question should be for a Brave developer… does Brave support the Native Messaging 1Password 6.8 is trying to use?

https://support.1password.com/kb/201707/

1Password 6.8 for Mac introduced a more reliable method for saving and filling in browsers called native messaging.

What you should do
If you see this message right after updating 1Password, it doesn’t mean your browser lacks support for native messaging. Try restarting your browser.

Restarting Brave does not work or solve this.

Opera, Vivaldi, and Chrome Canary all seem to have fixes, but not Brave so here is the advice I am given as a 1Password user…

If you use another browser

If you use another browser and you see this message, you should contact the developer and ask them to support native messaging.

If your browser supports native messaging, and you still see this message, contact 1Password Support and let us know.


#12

Also seems to be related to topic. 1Password 6.8 update doesn't work with Brave


#13

@rnsjunkmail @333 @zeb
There’s should be fixed in latest release. Please update your Brave version and see if the issue still persist.

Thank you,
:slight_smile: .


#14

It is fixed!!! That is great… THANK YOU!!! :grinning:


#15

I’ll leave this thread open for another couple days to be sure we don’t have any odd bugs, but if nobody pipes up by Tuesday, I’ll consider us fixed :slight_smile:


#16

It works if both 1Password and Brave are in the Applications folder, but NOT a subfolder. I hope this is fixed though, as I prefer to keep my web browsers together in a folder.


#17

I am running 1Password 6.8 and Brave 0.17.19, and I am still seeing this issue.


#18

@spaceman_spiff could you tell me which version number of 1Password extension is shown on about:preferences#extensions ?
Also, when is the last time you have restarted Brave?


#19

Still not working on fresh installation of Brave.

Brave 0.18.14 (ad92d02)
1Password Ext. 4.6.7.90
1Password 6.8 (680014)
macOS 10.12.6 (16G29)


#20

@alex sorry for the delay… oddly Brave 0.18.14 is working now in my user account on this Mac, but when I login to my wife’s account she gets the old “1Password can’t fill or save” message. Have tried restarting Brave and 1Password both.

macOS 10.12.6
Brave 0.18.14 (ad92d02)
1P Extension 4.6.3.90
1Password 6.8 (680015)