19.10 Eoan Repository InRelease Not Signed

I am trying to install brave but for Ubuntu 19.10 the repository wont update. I added the keyring from the website and I havent fround a solution as to why its not signed or whats wrong with the key. Is the Eoan InRelease not available yet?

@cory and @dan_brave please help

I assume you’re trying to install Brave Dev, correct?

Are you doing so using the following instructions?

sudo apt install apt-transport-https curl

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

source /etc/os-release

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ $UBUNTU_CODENAME main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-${UBUNTU_CODENAME}.list

sudo apt update

sudo apt install brave-browser 

Yes i used those instructions. Except its brave-browser-dev but i tried that one too and it dodnt work. Keeps saying that it is not signed. Then when i go to the link in the browser it says access denied.

I tried again today and still says InRelease not signed. I dont understand, is it not available for eaon dev yet or do I have to wait till 19.10 full release in october?